Upgrading from Dentrix 11 to Dentrix G4

Ah, the fun never stops with Dentrix.
As a part of the massive buildout of Forever Dental, we decided to upgrade from our aging Dentrix 11 to Dentrix G4 in order to better facilitate more than doubling the number of workstations that access the server.

A beautiful Saturday afternoon rolls around (one we’ve committed indoors to this upgrade).  We met the system requirements, walked through the Ten Installation Tips, and are ready to go.  We put the DVD in, cross our fingers, and press “Install Now”.

After clicking ‘Next’ a few times, we are greeted with this.

It reads “Database Conflict. The version of the database does not match the version of the DENTRIX program files”.

Since we had scheduled this upgrade on a Saturday afternoon, Dentrix Support was closed.

We were likely the first callers when Dentrix Support opened Monday morning.  After walking through the situation, our tech support rep told us that the issue is due to a couple of missing *.idx or *.dat files in the Dentrix/data directory.  We walked through every file that was supposed to be there (approximately 30), and, behold, it turns out that 3 were missing (LCM_Log.dat, LCM_Case.dat, LCM_Def.dat).  We would have to use Dentrix 11’s Selective Setup to install _only_ those three files.  The good news was that these files related to Lab Case Manager, which was never used in the practice.  The bad news was that this might destroy the entire database.  After completing the Selective Setup, we were to run Rebuild to rebuild the entire database, the continue with the upgrade.

We started the entire process again at 6PM, after the last patients left and after we backed up the system.  Selective Setup completed, Rebuild completed, and the data appeared sound.  We then ran G4 installation, and after a tense 20 minutes, it completed successfully.

Or so we thought.  Immediately after completion, I launched Appointment Book on the server.  Crash.  I launched Office Manager.  Success.  I clicked on Appointment Book from Office Manager.  Crash.  I wish I took a screenshot of that error that we got, because it was a scary looking one.

At this point the time read 6:58PM (Central time).  Dentrix Support closes at 7PM.  We called them immediately and thankfully they were open.  We spoke to another tech, and learned that Windows Server 2008 R2 does not by default install .NET Framework 3.5.1, and we had to do this manually.

I ran Server Manager and clicked on Features, then Add Feature.

I clicked on the + next to .NET Framework 3.5.1 and clicked the checkbox next to .NET Framework 3.5.1.  I specifically did NOT check WCF Activation (as indicated by the Dentrix Support tech).

I clicked Next and finished up the installation.
After completing this, Appointment Book opened successfully.

UPDATE:
Several days after the upgrade, everything seems to be running smoothly.

 

6 thoughts on “Upgrading from Dentrix 11 to Dentrix G4

  1. It’s always smart to leave this to someone specializing in dental computer technology that knows as much, if not more than the Dentrix support team about the program.

  2. im having the same issue too. when i tried to convert my dentrix 11 db during G4 installation, i got an error message indicating that the database is not 14. does anyone have a work around this issue or know how to fix this? anything would help. thank you in advance.

  3. Hello Jason, we’ve using G4 for about 4 years and just recently the computer when started did not automatically connect to the server which houses the Dentrix data. We fixed it but now the problem is : Database conflict! The version of the database does not match the version of the program. Expected version=14.2.1 Database version =14.1.0 How can this be fixed/ corrected?

    • This might an issue where you need to run the latest G4 Productivity Pack on each of the clients. This error message means that the server’s database version is later than the client (non-server) machine you are on. So, somehow, you ran a software upgrade on the server, and now you need to run the matching software upgrade on each of your clients.

      In general, whenever you upgrade the server Dentrix software, you have to go through and one-by-one upgrade each of your client machine’s Dentrix software as well, or you will see this error.

Leave a Reply to Jason Cancel reply

Your email address will not be published.